summaryrefslogtreecommitdiffstats
path: root/fish/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fish/Makefile.am')
-rw-r--r--fish/Makefile.am21
1 files changed, 13 insertions, 8 deletions
diff --git a/fish/Makefile.am b/fish/Makefile.am
index c8ba3ea4..795952a9 100644
--- a/fish/Makefile.am
+++ b/fish/Makefile.am
@@ -15,17 +15,26 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+include $(top_srcdir)/subdir-rules.mk
+
bin_PROGRAMS = guestfish
+generator_built = \
+ cmds.c \
+ completion.c
+
+BUILT_SOURCES = \
+ $(generator_built) \
+ rc_protocol.h \
+ rc_protocol.c
+
EXTRA_DIST = \
+ $(BUILT_SOURCES) \
rc_protocol.x
-CLEANFILES = rc_protocol.c rc_protocol.h
-
guestfish_SOURCES = \
+ $(generator_built) \
alloc.c \
- cmds.c \
- completion.c \
destpaths.c \
echo.c \
edit.c \
@@ -44,10 +53,6 @@ guestfish_SOURCES = \
librc_protocol_la_SOURCES = rc_protocol.c
librc_protocol_la_CFLAGS = -Wall -Wno-unused
-BUILT_SOURCES = \
- rc_protocol.c \
- rc_protocol.h
-
guestfish_CFLAGS = \
-I$(top_srcdir)/src -I$(top_builddir)/src \
-I$(top_srcdir)/fish -I$(top_builddir)/fish \