summaryrefslogtreecommitdiffstats
path: root/fish/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fish/Makefile.am')
-rw-r--r--fish/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/fish/Makefile.am b/fish/Makefile.am
index 03619f36..5255e853 100644
--- a/fish/Makefile.am
+++ b/fish/Makefile.am
@@ -29,10 +29,29 @@ guestfish_SOURCES = \
glob.c \
lcd.c \
more.c \
+ rc.c \
+ rc_protocol.c \
+ rc_protocol.h \
reopen.c \
time.c
+BUILT_SOURCES = \
+ rc_protocol.c \
+ rc_protocol.h
+
guestfish_CFLAGS = \
-I$(top_srcdir)/src -I$(top_builddir)/src -Wall \
-DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
guestfish_LDADD = $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
+
+if HAVE_RPCGEN
+rc_protocol.c: rc_protocol.x
+ rm -f $@-t
+ $(RPCGEN) -c -o $@-t $<
+ mv $@-t $@
+
+rc_protocol.h: rc_protocol.x
+ rm -f $@-t
+ $(RPCGEN) -h -o $@-t $<
+ mv $@-t $@
+endif