summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 88772605..0d582faa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -784,6 +784,11 @@ AS_IF([test "x$VALGRIND" != "xno"],[
AC_MSG_RESULT([no])
AC_SUBST([VALGRIND_NO_VGDB],[])
fi
+
+ # Substitute the whole valgrind command.
+ VG='$(VALGRIND) $(VALGRIND_NO_VGDB) --log-file=$(abs_top_builddir)/valgrind.log --leak-check=full --error-exitcode=119 --suppressions=$(abs_top_srcdir)/valgrind-suppressions'
+ AC_SUBST([VG])
+ AM_SUBST_NOTMAKE([VG])
])
dnl Check for OCaml (optional, for OCaml bindings and OCaml tools).