summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8fac31c8..57c01be0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,6 +107,8 @@ if test "$gl_gcc_warnings" = yes; then
# by Python, Ruby and xstrtoll.
nw="$nw -Wstack-protector" # Don't warn about stack-protector
# failures (seen on Ubuntu).
+ nw="$nw -Wmissing-noreturn" # Don't warn about missed noreturn funcs
+ # (seen on Ubuntu).
gl_MANYWARN_ALL_GCC([ws])
gl_MANYWARN_COMPLEMENT([ws], [$ws], [$nw])