summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3e364b12..ebc20aa7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -264,8 +264,23 @@ if test "x$enable_daemon" = "xyes"; then
[],
[enable_install_daemon=no])
AC_MSG_RESULT([$enable_install_daemon])
+
+ dnl Enable valgrind in the daemon.
+ AC_MSG_CHECKING([if we should run the daemon under valgrind])
+ AC_ARG_ENABLE([valgrind-daemon],
+ [AS_HELP_STRING([--enable-valgrind-daemon],
+ [run the daemon under valgrind (developers only) @<:@default=no@:>@])],
+ [],
+ [enable_valgrind_daemon=no])
+ AC_MSG_RESULT([$enable_valgrind_daemon])
+
+ if test "x$enable_valgrind_daemon" = "xyes"; then
+ AC_DEFINE([VALGRIND_DAEMON],[1],[Define to 1 to run the daemon under valgrind])
+ AC_DEFINE_UNQUOTED([VALGRIND_LOG_PATH],["$(pwd)"],[Path to save valgrind log files])
+ fi
fi
AM_CONDITIONAL([INSTALL_DAEMON],[test "x$enable_install_daemon" = "xyes"])
+AM_CONDITIONAL([VALGRIND_DAEMON],[test "x$enable_valgrind_daemon" = "xyes"])
dnl Build the appliance?
AC_MSG_CHECKING([if we should build the appliance])