summaryrefslogtreecommitdiffstats
path: root/capitests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'capitests/Makefile.am')
-rw-r--r--capitests/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/capitests/Makefile.am b/capitests/Makefile.am
new file mode 100644
index 00000000..f061243b
--- /dev/null
+++ b/capitests/Makefile.am
@@ -0,0 +1,49 @@
+# libguestfs
+# Copyright (C) 2009 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+EXTRA_DIST = \
+ tests.c \
+ test-cleanup.sh \
+ test-bootbootboot.sh
+
+# Tests. These are auto-generated from the test descriptions
+# in the generator.
+
+check_PROGRAMS = tests test-command
+
+tests_SOURCES = tests.c
+tests_CFLAGS = \
+ -I$(top_builddir)/src -Wall
+tests_LDADD = $(top_builddir)/src/libguestfs.la
+
+TESTS = tests test-bootbootboot.sh
+TESTS_ENVIRONMENT = \
+ SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
+ SKIP_TEST_COMMAND_LINES=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
+ SKIP_TEST_ZEROFREE=$(shell test -x ../initramfs/usr/sbin/zerofree || echo 1) \
+ $(VG)
+
+# Run the tests under valgrind.
+
+valgrind:
+ $(MAKE) check VG="valgrind --quiet --leak-check=full"
+
+# This binary must be statically linked. It is used for testing
+# the "guestfs_command" and "guestfs_command_lines" functions.
+
+test_command_SOURCES = test-command.c
+test_command_LDFLAGS = -all-static