summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 55e5dde9..47954a50 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,6 +61,17 @@ $(INITRAMFSIMG): initramfs/fakeroot.log daemon/guestfsd
bash $(builddir)/update-initramfs.sh
touch $@
+# Tests. These are auto-generated from the test descriptions.
+
+check_PROGRAMS = tests
+
+tests_SOURCES = tests.c
+tests_CFLAGS = \
+ -I$(top_builddir)/src -Wall
+tests_LDADD = $(top_builddir)/src/libguestfs.la
+
+TESTS = $(check_PROGRAMS)
+
# Manual pages.
# guestfs-actions.pod and guestfs-structs are autogenerated. There is
# no include mechanism for POD, so we have to do it by hand.