summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fcf5f614..50c9e7d4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,7 +103,9 @@ tests_CFLAGS = \
tests_LDADD = $(top_builddir)/src/libguestfs.la
TESTS = tests
-TESTS_ENVIRONMENT = $(VG)
+TESTS_ENVIRONMENT = \
+ SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
+ $(VG)
$(TESTS): $(INITRAMFS) $(VMLINUZ)