summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d34b9429..241a0a8d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,6 +32,7 @@ endif
EXTRA_DIST = \
make-initramfs.sh update-initramfs.sh \
guestfs.pod guestfs-actions.pod guestfs-structs.pod \
+ guestfish.pod guestfish-actions.pod \
libguestfs.spec \
HACKING
@@ -66,11 +67,11 @@ CLEANFILES = $(fs_DATA) emptydisk
clean-local:
rm -rf initramfs
-# Manual page.
+# Manual pages.
# guestfs-actions.pod and guestfs-structs are autogenerated. There is
# no include mechanism for POD, so we have to do it by hand.
-man_MANS = guestfs.3
+man_MANS = guestfs.3 guestfish.1
guestfs.3: guestfs.pod guestfs-actions.pod guestfs-structs.pod
sed \
@@ -84,6 +85,17 @@ guestfs.3: guestfs.pod guestfs-actions.pod guestfs-structs.pod
--release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
> $@
+guestfish.1: guestfish.pod guestfish-actions.pod
+ sed \
+ -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
+ < $< | \
+ $(POD2MAN) \
+ --section 1 \
+ -c "Virtualization Support" \
+ --name "guestfish" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ > $@
+
# Test-boot the image.
test-boot: emptydisk