summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 25 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 9332a10d..bbdb0ed4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,8 +57,9 @@ SUBDIRS += haskell
endif
generator_built = \
- guestfs-structs.pod \
guestfs-actions.pod \
+ guestfs-availability.pod \
+ guestfs-structs.pod \
guestfish-actions.pod
EXTRA_DIST = \
@@ -83,15 +84,23 @@ EXTRA_DIST = \
libguestfs.3
# Manual pages.
-# guestfs-actions.pod and guestfs-structs are autogenerated. There is
-# no include mechanism for POD, so we have to do it by hand.
+# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs
+# are autogenerated. There is no include mechanism for POD, so we
+# have to do it by hand.
man_MANS = guestfs.3 libguestfs.3 guestfish.1
-guestfs.3: guestfs.pod guestfs-actions.pod guestfs-structs.pod
+guestfs.3: guestfs.pod \
+ guestfs-actions.pod \
+ guestfs-availability.pod \
+ guestfs-structs.pod
sed \
- -e '/@ACTIONS@/rguestfs-actions.pod' -e 's/@ACTIONS@//' \
- -e '/@STRUCTS@/rguestfs-structs.pod' -e 's/@STRUCTS@//' \
+ -e '/@ACTIONS@/rguestfs-actions.pod' \
+ -e 's/@ACTIONS@//' \
+ -e '/@AVAILABILITY@/rguestfs-availability.pod' \
+ -e 's/@AVAILABILITY@//' \
+ -e '/@STRUCTS@/rguestfs-structs.pod' \
+ -e 's/@STRUCTS@//' \
< $< | \
$(POD2MAN) \
--section 3 \
@@ -113,11 +122,18 @@ guestfish.1: guestfish.pod guestfish-actions.pod
noinst_DATA = html/guestfs.3.html html/guestfish.1.html
-html/guestfs.3.html: guestfs.pod guestfs-actions.pod guestfs-structs.pod
+html/guestfs.3.html: guestfs.pod \
+ guestfs-actions.pod \
+ guestfs-availability.pod \
+ guestfs-structs.pod
mkdir -p html
sed \
- -e '/@ACTIONS@/rguestfs-actions.pod' -e 's/@ACTIONS@//' \
- -e '/@STRUCTS@/rguestfs-structs.pod' -e 's/@STRUCTS@//' \
+ -e '/@ACTIONS@/rguestfs-actions.pod' \
+ -e 's/@ACTIONS@//' \
+ -e '/@AVAILABILITY@/rguestfs-availability.pod' \
+ -e 's/@AVAILABILITY@//' \
+ -e '/@STRUCTS@/rguestfs-structs.pod' \
+ -e 's/@STRUCTS@//' \
< $< | \
pod2html \
--css 'pod.css' \