summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e2b49d6..39cf86cf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,7 @@ SUBDIRS = src daemon fish examples
EXTRA_DIST = \
make-initramfs.sh update-initramfs.sh \
- guestfs.pod guestfs-actions.pod \
+ guestfs.pod guestfs-actions.pod guestfs-structs.pod \
libguestfs.spec \
HACKING
@@ -57,13 +57,16 @@ clean-local:
rm -rf initramfs
# Manual page.
-# guestfs-actions.pod is autogenerated. There is no include mechanism
-# for POD, so we have to do it by hand.
+# guestfs-actions.pod and guestfs-structs are autogenerated. There is
+# no include mechanism for POD, so we have to do it by hand.
man_MANS = guestfs.3
-guestfs.3: guestfs.pod guestfs-actions.pod
- sed -e '/@ACTIONS@/rguestfs-actions.pod' -e 's/@ACTIONS@//' < $< | \
+guestfs.3: guestfs.pod guestfs-actions.pod guestfs-structs.pod
+ sed \
+ -e '/@ACTIONS@/rguestfs-actions.pod' -e 's/@ACTIONS@//' \
+ -e '/@STRUCTS@/rguestfs-structs.pod' -e 's/@STRUCTS@//' \
+ < $< | \
$(POD2MAN) \
--section 3 \
-c "Virtualization Support" \