summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-11-24 15:19:33 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-11-24 20:12:08 +0000
commite1aca6323e33e0dd50e23dc0d638f5789c9188e4 (patch)
tree2ae931f496aa992108d0f54bb82b8e24685918cc /tools/Makefile.am
parentc1592ac93886e7f39a6017272b2486d3f411d054 (diff)
downloadlibguestfs-e1aca6323e33e0dd50e23dc0d638f5789c9188e4.tar.gz
libguestfs-e1aca6323e33e0dd50e23dc0d638f5789c9188e4.tar.xz
libguestfs-e1aca6323e33e0dd50e23dc0d638f5789c9188e4.zip
build: Centralize all POD manipulation in 'podwrapper.sh' script.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am17
1 files changed, 6 insertions, 11 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index c5131bd8..4ab83696 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -49,19 +49,14 @@ man_MANS = virt-df.1 $(patsubst %,virt-%.1,$(filter-out df,$(tools)))
noinst_DATA = $(tools:%=$(top_builddir)/html/virt-%.1.html)
virt-%.1: virt-%
- $(POD2MAN) \
- --section 1 \
- -c "Virtualization Support" \
- --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
- $< > $@-t && mv $@-t $@
+ $(top_srcdir)/podwrapper.sh \
+ --man $@ \
+ $<
$(top_builddir)/html/virt-%.1.html: virt-%
- mkdir -p $(top_builddir)/html
- cd $(top_builddir) && pod2html \
- --css 'pod.css' \
- --htmldir html \
- --outfile html/$<.1.html \
- tools/$<
+ $(top_srcdir)/podwrapper.sh \
+ --html $@ \
+ $<
# Tests.