summaryrefslogtreecommitdiffstats
path: root/tests/extra/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-07-07 16:19:55 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-07-07 16:19:55 +0100
commite6dec159488f589df62c9f59477281f8264a19c8 (patch)
tree8847b8ae4338506cc2f2616cd4ab155a66d277d6 /tests/extra/Makefile.am
parent6e5a85bb9b6557bc337625a339728e23f5f2dd94 (diff)
downloadlibguestfs-e6dec159488f589df62c9f59477281f8264a19c8.tar.gz
libguestfs-e6dec159488f589df62c9f59477281f8264a19c8.tar.xz
libguestfs-e6dec159488f589df62c9f59477281f8264a19c8.zip
extra-tests: Add a test using upstream qemu.
Diffstat (limited to 'tests/extra/Makefile.am')
-rw-r--r--tests/extra/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/tests/extra/Makefile.am b/tests/extra/Makefile.am
index 4e56aedc..bd34d9a1 100644
--- a/tests/extra/Makefile.am
+++ b/tests/extra/Makefile.am
@@ -23,6 +23,7 @@
# (tip: add yourself to the 'disk' group)
# - valgrind
# - libtool
+# - qemu in $QEMUDIR
#
# These tests may fail for reasons which aren't necessarily real problems.
#
@@ -88,7 +89,8 @@ extra-tests: \
test-sysprep-real \
test-ocaml \
test-resize \
- test-sparsify
+ test-sparsify \
+ test-upstream-qemu
test-guests:
$(MAKE) -C ../guests check
@@ -184,3 +186,18 @@ test-c-api:
# Test OCaml bindings under valgrind.
test-ocaml:
$(MAKE) -C ../../ocaml VG="$(VG)" check
+
+# When running the extra tests, if directory $HOME/d/qemu exists then
+# we will try to run the basic tests using the version of qemu from
+# that directory. eg. That might be qemu from git.
+#
+# The directory name can be overridden using:
+# make extra-tests QEMUDIR=/path/to/other/qemu
+
+QEMUDIR = $(HOME)/d/qemu
+export QEMUDIR
+export abs_srcdir
+export MAKE
+
+test-upstream-qemu:
+ ./test-upstream-qemu.sh