summaryrefslogtreecommitdiffstats
path: root/test-tool/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-07-22 20:58:39 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-07-22 23:00:30 +0100
commitf9de01b9b97e3d13959754446464f9b768deea81 (patch)
treefac97067ca92b306e6c1761c66b976c00b0ee04f /test-tool/Makefile.am
parent26f69f706e8c661c6ae7946da1b9a4b7bf9150b9 (diff)
downloadlibguestfs-f9de01b9b97e3d13959754446464f9b768deea81.tar.gz
libguestfs-f9de01b9b97e3d13959754446464f9b768deea81.tar.xz
libguestfs-f9de01b9b97e3d13959754446464f9b768deea81.zip
Add libguestfs-test-tool.
This is an end-user testing tool, designed to test basic functionality of libguestfs/qemu/kernel combination on the end-user's final host machine. It does not perform a thorough test, but should be enough to find most booting issues. Also this is intended to be used when reporting bugs.
Diffstat (limited to 'test-tool/Makefile.am')
-rw-r--r--test-tool/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/test-tool/Makefile.am b/test-tool/Makefile.am
new file mode 100644
index 00000000..510a42fc
--- /dev/null
+++ b/test-tool/Makefile.am
@@ -0,0 +1,44 @@
+# libguestfs
+# Copyright (C) 2009 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+EXTRA_DIST = libguestfs-test-tool.pod
+
+CLEANFILES =
+
+bin_PROGRAMS = libguestfs-test-tool
+libexec_PROGRAMS = libguestfs-test-tool-helper
+man_MANS = libguestfs-test-tool.1
+
+AM_CPPFLAGS = \
+ -DDEFAULT_HELPER='"$(libexecdir)/libguestfs-test-tool-helper"'
+
+libguestfs_test_tool_SOURCES = test-tool.c
+libguestfs_test_tool_CFLAGS = \
+ -I$(top_srcdir)/src -I$(top_builddir)/src \
+ -Wall
+libguestfs_test_tool_LDADD = \
+ $(top_builddir)/src/libguestfs.la
+
+libguestfs_test_tool_helper_SOURCES = helper.c
+libguestfs_test_tool_helper_LDFLAGS = -all-static
+
+libguestfs-test-tool.1: libguestfs-test-tool.pod
+ $(POD2MAN) \
+ --section 1 \
+ -c "Virtualization Support" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ $< > $@