summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-07-16 18:23:53 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-07-16 18:23:53 +0100
commit811b4a51dc25219e19527304892e7f688867e105 (patch)
tree9f1f7413dac87b1cbce0601a33aa214f3d6a00c1 /src/Makefile.am
parent98515732084c6856c2e22364b2ae64113c2c37c6 (diff)
downloadlibguestfs-811b4a51dc25219e19527304892e7f688867e105.tar.gz
libguestfs-811b4a51dc25219e19527304892e7f688867e105.tar.xz
libguestfs-811b4a51dc25219e19527304892e7f688867e105.zip
Fix for non-srcdir builds: more misc fixes.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1906378d..c6006d2b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,8 +17,6 @@
EXTRA_DIST = \
guestfs_protocol.x \
- guestfs_protocol.c \
- guestfs_protocol.h \
MAX_PROC_NR \
stamp-generator \
generator.ml
@@ -52,6 +50,8 @@ BUILT_SOURCES = \
$(BUILT_SOURCES): stamp-generator
+CLEANFILES = guestfs_protocol.c guestfs_protocol.h
+
# From the libtool info file, with comments:
#
# | 1. Start with version information of `0:0:0' for each libtool library.
@@ -109,9 +109,11 @@ libguestfs_la_CFLAGS = -Wall -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
if HAVE_RPCGEN
guestfs_protocol.c: guestfs_protocol.x
- rm -f $@-t
+ rm -f $@-t $@-t2
$(RPCGEN) -c -o $@-t $<
- mv $@-t $@
+ sed 's,\.\./\.\./src/,,' < $@-t > $@-t2
+ rm $@-t
+ mv $@-t2 $@
guestfs_protocol.h: guestfs_protocol.x
rm -f $@-t