summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMatthew Booth <mbooth@redhat.com>2011-04-07 15:30:54 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-04-07 16:37:20 +0100
commit3a84e0784e1e3ab7b56850d0f8c9aa42f1ae3da1 (patch)
treeb48d5f29ed2bedb87305fd54de1633bf796322fb /src/Makefile.am
parent6ea263b1f141614e7693a38b13e8f368237760a2 (diff)
downloadlibguestfs-3a84e0784e1e3ab7b56850d0f8c9aa42f1ae3da1.tar.gz
libguestfs-3a84e0784e1e3ab7b56850d0f8c9aa42f1ae3da1.tar.xz
libguestfs-3a84e0784e1e3ab7b56850d0f8c9aa42f1ae3da1.zip
Compile rpcgen-generated files with -fno-strict-aliasing
rpcgen generates source which can't be safely compiled with strict-aliasing enabled.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3e1201d1..42cc906e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -52,13 +52,10 @@ include_HEADERS = guestfs.h
lib_LTLIBRARIES = libguestfs.la
-# This convenience library is solely to avoid compiler warnings
-# in its generated sources.
-libprotocol_la_SOURCES = \
- guestfs_protocol.c \
- guestfs_protocol.h
-
-libprotocol_la_CFLAGS =
+# This convenience library is solely to compile its generated sources with
+# custom flags.
+libprotocol_la_SOURCES = guestfs_protocol.c guestfs_protocol.h
+libprotocol_la_CFLAGS = -Wall -Wno-unused -fno-strict-aliasing
# Build the errnostring perfect hash code. The generated code has lots
# of warnings so we must compile it in a separate mini-library.