summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-07-16 18:08:44 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-07-16 18:08:44 +0100
commit98515732084c6856c2e22364b2ae64113c2c37c6 (patch)
tree19aefd5150ecda1b63403b3a8fea3ebcaeed9a7e /src/Makefile.am
parenta865795a7edfdc939cf3864ca1b7ea9cdc564dc7 (diff)
downloadlibguestfs-98515732084c6856c2e22364b2ae64113c2c37c6.tar.gz
libguestfs-98515732084c6856c2e22364b2ae64113c2c37c6.tar.xz
libguestfs-98515732084c6856c2e22364b2ae64113c2c37c6.zip
Fix for non-srcdir builds: Run src/generator.ml from the srcdir.
Note that files generated by src/generator.ml are stored in the srcdir, *not* the builddir. The reason is so that they can be included in the tarball and will appear in the srcdir for tarball builds.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 292e2ecc..1906378d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -30,10 +30,10 @@ EXTRA_DIST = \
noinst_DATA = stamp-generator
stamp-generator: generator.ml
- mkdir -p $(top_builddir)/perl/lib/Sys
- mkdir -p $(top_builddir)/ruby/ext/guestfs
- mkdir -p $(top_builddir)/java/com/redhat/et/libguestfs
- cd $(top_builddir) && ocaml -warn-error A ./src/$<
+ mkdir -p $(top_srcdir)/perl/lib/Sys
+ mkdir -p $(top_srcdir)/ruby/ext/guestfs
+ mkdir -p $(top_srcdir)/java/com/redhat/et/libguestfs
+ cd $(top_srcdir) && ocaml -warn-error A src/generator.ml
guestfs_protocol.x: stamp-generator