summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-07-02 11:29:00 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-07-02 11:51:07 +0100
commitda85ed425dc828ef4b8817f64d448101a88507b5 (patch)
tree238dd3bcad6cfd62874b0c279aa6cfbeecb40bd4 /src/Makefile.am
parent5186251f8f681f2ebb028423bb49a748861fd11e (diff)
downloadlibguestfs-da85ed425dc828ef4b8817f64d448101a88507b5.tar.gz
libguestfs-da85ed425dc828ef4b8817f64d448101a88507b5.tar.xz
libguestfs-da85ed425dc828ef4b8817f64d448101a88507b5.zip
Generator now runs automatically when it has changed.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 06d4522c..eb8723a2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,12 +15,25 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-EXTRA_DIST = guestfs_protocol.x \
+EXTRA_DIST = \
+ guestfs_protocol.x \
guestfs_protocol.c \
guestfs_protocol.h \
- MAX_PROC_NR
+ MAX_PROC_NR \
+ stamp-generator \
+ generator.ml
-EXTRA_DIST += generator.ml
+# Rerun the generator if it has changed.
+# Git removes empty directories, so in cases where the
+# generator is creating the sole file in a directory, we
+# have to create the directory first.
+noinst_DATA = stamp-generator
+
+stamp-generator: generator.ml
+ mkdir -p $(top_srcdir)/perl/lib/Sys
+ cd .. && ocaml -warn-error A $(srcdir)/src/$<
+
+guestfs_protocol.x: stamp-generator
include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h