summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-07-28 15:40:42 +0100
committerRichard Jones <rjones@redhat.com>2010-08-17 14:09:25 +0100
commit8289aa1ad68ec94c87fc4d538f638d8816052d92 (patch)
treedcd5830a796849d0a5b0c7f2ee2854e503f2c2a6 /src/Makefile.am
parent65e9ac4595fbace8f301030469932be518456246 (diff)
downloadlibguestfs-8289aa1ad68ec94c87fc4d538f638d8816052d92.tar.gz
libguestfs-8289aa1ad68ec94c87fc4d538f638d8816052d92.tar.xz
libguestfs-8289aa1ad68ec94c87fc4d538f638d8816052d92.zip
New APIs for guest inspection.
This commit converts (some of) the Perl inspection code to C and makes it available through core APIs. The new APIs are: inspect-os - Does the inspection, returns list of OSes inspect-get-* - Get results of the inspection where '*' is one of: type - 'windows' or 'linux' distro - Linux distro arch - architecture product-name - long product name string major-version minor-version - major.minor version of OS mountpoints - get a list of the mountpoints filesystems - get all filesystems associated with the OS This works for all existing supported Linux and Windows OSes.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 61cec04e..cc014591 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -131,7 +131,7 @@ libguestfs_la_SOURCES = \
proto.c \
libguestfs.syms
-libguestfs_la_LIBADD = $(LIBPCRE) $(LIBMAGIC) $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+libguestfs_la_LIBADD = $(HIVEX_LIBS) $(LIBPCRE) $(LIBMAGIC) $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
# Make libguestfs include the convenience library.
noinst_LTLIBRARIES = libprotocol.la
@@ -139,6 +139,7 @@ libguestfs_la_LIBADD += libprotocol.la
libguestfs_la_CFLAGS = \
-DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+ $(HIVEX_CFLAGS) \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib