summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-07-27 13:01:39 +0100
committerRichard Jones <rjones@redhat.com>2010-07-27 13:05:41 +0100
commit41f25ab3df5f306ac717fa7a6efd58328d30c1ae (patch)
tree461e3e42a668ba1d8f0f6511a677879ee8fa61c3 /src/Makefile.am
parenta617f521a4f695a63ced1c734128dc6c05b7024f (diff)
downloadlibguestfs-41f25ab3df5f306ac717fa7a6efd58328d30c1ae.tar.gz
libguestfs-41f25ab3df5f306ac717fa7a6efd58328d30c1ae.tar.xz
libguestfs-41f25ab3df5f306ac717fa7a6efd58328d30c1ae.zip
Rearrange library code into separate files.
We split the library code into these separate files: - guestfs.c: creating handles, closing handles, handle-related variables - actions.c: generated library-side stubs for each action - bindtests.c: generated code to test bindings - launch.c: launching the appliance - proto.c: the library side of the daemon communications protocol This is just code movement.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0776c65f..4135c8c9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -126,6 +126,8 @@ libguestfs_la_SOURCES = \
gettext.h \
actions.c \
bindtests.c \
+ launch.c \
+ proto.c \
libguestfs.syms
libguestfs_la_LIBADD = $(LTLIBTHREAD) ../gnulib/lib/libgnu.la