summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-09-11 09:25:12 +0100
committerRichard Jones <rjones@redhat.com>2010-09-11 12:04:44 +0100
commit04d8209077d2227eb1d42695ba71147f78987050 (patch)
treea2ed4a062f70fe258d0fd9b60020c24f6dc7459c /src/Makefile.am
parent264629b9f0ace1062b453b2d0ae55e48385189d3 (diff)
downloadlibguestfs-04d8209077d2227eb1d42695ba71147f78987050.tar.gz
libguestfs-04d8209077d2227eb1d42695ba71147f78987050.tar.xz
libguestfs-04d8209077d2227eb1d42695ba71147f78987050.zip
Split generator into separate source files.
'src/generator.ml' is no more. Instead the generator is logically split up over many different source files. Read generator/README for help and tips. We compile the generator down to bytecode, not native code. This means it will run more slowly, but is done for maximum portability.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 1 insertions, 20 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 22879e3f..7b88d8b9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
# libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2010 Red Hat Inc.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -29,8 +29,6 @@ generator_built = \
guestfs-structs.pod \
libguestfs.syms
-$(generator_built): stamp-generator
-
BUILT_SOURCES = \
$(generator_built) \
guestfs_protocol.c \
@@ -39,27 +37,10 @@ BUILT_SOURCES = \
EXTRA_DIST = \
$(BUILT_SOURCES) \
MAX_PROC_NR \
- stamp-generator \
generator.ml \
libguestfs.3 \
guestfs.pod
-# Rerun the generator if it has changed.
-# Git removes empty directories, so in cases where the
-# generator is creating the sole file in a directory, we
-# have to create the directory first.
-noinst_DATA = stamp-generator
-
-stamp-generator: generator.ml ../images/test.iso
- mkdir -p $(top_srcdir)/perl/lib/Sys
- mkdir -p $(top_srcdir)/ruby/ext/guestfs
- mkdir -p $(top_srcdir)/java/com/redhat/et/libguestfs
- mkdir -p $(top_srcdir)/csharp
- cd $(top_srcdir) && ocaml -warn-error A src/generator.ml
-
-../images/test.iso:
- make -C ../images test.iso
-
include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
lib_LTLIBRARIES = libguestfs.la