summaryrefslogtreecommitdiffstats
path: root/ruby/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-16 22:13:20 +0100
committerRichard Jones <rjones@redhat.com>2009-04-16 22:13:20 +0100
commita5f68bd57d887c8c8818dbb92a9f8b7643f67827 (patch)
treefc9004be7e62c8cadb54eeff1b7ad5b763ff4073 /ruby/Makefile.am
parent5a6da98c943be987441673a590c151f15573b6cc (diff)
downloadlibguestfs-a5f68bd57d887c8c8818dbb92a9f8b7643f67827.tar.gz
libguestfs-a5f68bd57d887c8c8818dbb92a9f8b7643f67827.tar.xz
libguestfs-a5f68bd57d887c8c8818dbb92a9f8b7643f67827.zip
Ruby bindings.
Diffstat (limited to 'ruby/Makefile.am')
-rw-r--r--ruby/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/ruby/Makefile.am b/ruby/Makefile.am
new file mode 100644
index 00000000..2b4b2010
--- /dev/null
+++ b/ruby/Makefile.am
@@ -0,0 +1,43 @@
+# libguestfs Ruby bindings
+# Copyright (C) 2009 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+EXTRA_DIST = \
+ Rakefile.in \
+ ext/guestfs/_guestfs.c \
+ ext/guestfs/extconf.rb \
+ lib/guestfs.rb \
+ run-ruby-tests \
+ tests/tc_*.rb
+
+CLEANFILES = *~ \
+ lib/*~ \
+ tests/*~ \
+ ext/guestfs/*~ \
+ ext/guestfs/extconf.h \
+ ext/guestfs/_guestfs.o \
+ ext/guestfs/_guestfs.so \
+ ext/guestfs/mkmf.log \
+ ext/guestfs/Makefile
+
+if HAVE_RUBY
+
+TESTS = run-ruby-tests
+
+all:
+ rake build
+
+endif \ No newline at end of file