summaryrefslogtreecommitdiffstats
path: root/regressions/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-07-06 13:10:25 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-07-06 13:10:25 +0100
commit51ecd63944bb1374ebad518d814deaa2096bc365 (patch)
tree7ef6b1daea5d66f3516a4ef47416d638a2f4adec /regressions/Makefile.am
parentf1fadb92179b68519b57680718e30a389a63d5e5 (diff)
downloadlibguestfs-51ecd63944bb1374ebad518d814deaa2096bc365.tar.gz
libguestfs-51ecd63944bb1374ebad518d814deaa2096bc365.tar.xz
libguestfs-51ecd63944bb1374ebad518d814deaa2096bc365.zip
Introduce regression tests for various qemu failures.
Test failure of qemu and recovery of the library: - mid-command - between commands - during launch [test not working yet] - explicitly killed by guestfs_kill_subprocess Also this patch cleans up the other tests in this directory and disables the long-winded test-bootbootboot test.
Diffstat (limited to 'regressions/Makefile.am')
-rw-r--r--regressions/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/regressions/Makefile.am b/regressions/Makefile.am
index 78ecfaa4..874e898e 100644
--- a/regressions/Makefile.am
+++ b/regressions/Makefile.am
@@ -24,8 +24,21 @@
TESTS = \
rhbz503169c10.sh \
rhbz503169c13.sh \
+ test-qemudie-midcommand.sh \
+ test-qemudie-killsub.sh \
+ test-qemudie-synch.sh
+
+SKIPPED_TESTS = \
test-bootbootboot.sh
+FAILING_TESTS = \
+ test-qemudie-launchfail.sh
+
+TESTS_ENVIRONMENT = \
+ LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+ LIBGUESTFS_PATH=$(top_builddir)/appliance
+
EXTRA_DIST = \
- test-cleanup.sh \
+ $(FAILING_TESTS) \
+ $(SKIPPED_TESTS) \
$(TESTS)