summaryrefslogtreecommitdiffstats
path: root/regressions/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-03-18 13:48:03 +0000
committerRichard Jones <rjones@redhat.com>2010-03-18 15:21:08 +0000
commit50d2af4f8541a81d047753d7d300804ff649230c (patch)
tree8bc80cd1004314574e9354c2215fd8485f3e3676 /regressions/Makefile.am
parent27e73269d384814eb5f76468f609f7844cb75b0b (diff)
downloadlibguestfs-50d2af4f8541a81d047753d7d300804ff649230c.tar.gz
libguestfs-50d2af4f8541a81d047753d7d300804ff649230c.tar.xz
libguestfs-50d2af4f8541a81d047753d7d300804ff649230c.zip
New APIs: Query the relationship between LVM objects.
These calls allow you to query the relationship between LVM objects, for example, which PVs contain a VG, or which LVs are contained in a VG. See the example / test program 'regressions/test-lvm-mapping.pl' for an example of how to do this from Perl.
Diffstat (limited to 'regressions/Makefile.am')
-rw-r--r--regressions/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/regressions/Makefile.am b/regressions/Makefile.am
index 4ac0ee0d..2710e824 100644
--- a/regressions/Makefile.am
+++ b/regressions/Makefile.am
@@ -30,6 +30,7 @@ TESTS = \
test-cancellation-download-librarycancels.sh \
test-cancellation-upload-daemoncancels.sh \
test-find0.sh \
+ test-lvm-mapping.pl \
test-noexec-stack.pl \
test-qemudie-killsub.sh \
test-qemudie-midcommand.sh \
@@ -51,6 +52,7 @@ TESTS_ENVIRONMENT = \
MALLOC_PERTURB_=$(random_val) \
LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
LIBGUESTFS_PATH=$(top_builddir)/appliance \
+ PERL5LIB=$(top_builddir)/perl/blib/lib:$(top_builddir)/perl/blib/arch \
NOEXEC_CHECK="$(top_builddir)/src/.libs/libguestfs.so $(top_builddir)/daemon/guestfsd"
EXTRA_DIST = \