summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-04-22 19:58:29 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-04-22 21:50:15 +0100
commit16da7589e91b0030fb5564553447f80b97c0b18c (patch)
tree525ea8ac1d5e28fde2becc9e928dbc1750d01c03 /python/Makefile.am
parent3acf732c2f23d8508f692efb2b222169914bfcdc (diff)
downloadlibguestfs-16da7589e91b0030fb5564553447f80b97c0b18c.tar.gz
libguestfs-16da7589e91b0030fb5564553447f80b97c0b18c.tar.xz
libguestfs-16da7589e91b0030fb5564553447f80b97c0b18c.zip
python: Rearrange C files for bindings.
Move the hand-written functions into two new files: guestfs-py.h and guestfs-py-byhand.c This is just code motion.
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 1fde976f..76b92fdf 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -39,7 +39,7 @@ python_DATA = guestfs.py
python_LTLIBRARIES = libguestfsmod.la
-libguestfsmod_la_SOURCES = guestfs-py.c
+libguestfsmod_la_SOURCES = guestfs-py.c guestfs-py.h guestfs-py-byhand.c
libguestfsmod_la_CFLAGS = -Wall -I$(PYTHON_INCLUDEDIR) \
-I$(top_srcdir)/src -I$(top_builddir)/src
libguestfsmod_la_LIBADD = $(top_builddir)/src/libguestfs.la