summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-13 18:32:03 +0100
committerRichard Jones <rjones@redhat.com>2009-04-13 18:32:03 +0100
commitb3f11c5f62f725fa3f09452b38d52dba764f80d0 (patch)
tree6f1ebeb0d33d0e7cf027be217e75624f47097864 /python/Makefile.am
parentf968f6c36fda3bb66cd37cd56de250c29afa7698 (diff)
downloadlibguestfs-b3f11c5f62f725fa3f09452b38d52dba764f80d0.tar.gz
libguestfs-b3f11c5f62f725fa3f09452b38d52dba764f80d0.tar.xz
libguestfs-b3f11c5f62f725fa3f09452b38d52dba764f80d0.zip
Lots, mainly Python bindings.
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 509e87ca..b2cf3b34 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -15,10 +15,27 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-EXTRA_DIST = README-python-bindings
+EXTRA_DIST = \
+ guestfs.py \
+ guestfs-py.c \
+ t/*.py
CLEANFILES = *~
if HAVE_PYTHON
+pythondir = $(PYTHON_SITE_PACKAGES)
+
+python_LTLIBRARIES = libguestfsmod.la
+
+libguestfsmod_la_SOURCES = guestfs-py.c
+libguestfsmod_la_CFLAGS = -Wall -I$(PYTHON_INCLUDEDIR) -I$(top_builddir)/src
+libguestfsmod_la_LIBADD = $(top_builddir)/src/libguestfs.la
+
+TESTS_ENVIRONMENT = \
+ LIBGUESTFS_PATH=$(abs_top_builddir) \
+ PYTHONPATH=$(abs_top_builddir)/python:$(abs_top_builddir)/python/.libs \
+ $(PYTHON)
+TESTS = t/005-import.py t/010-launch.py t/050-lvcreate.py
+
endif \ No newline at end of file