summaryrefslogtreecommitdiffstats
path: root/perl/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-08 17:19:09 +0100
committerRichard Jones <rjones@redhat.com>2009-04-08 17:19:09 +0100
commitb5ff6816face6f8c1700d4f1df752c710620ff95 (patch)
tree1ceb5097496c27ed3541e0b341b60a6b88e85ace /perl/Makefile.am
parentc3168fc03cdff6be5638107b12f74bc895af55ed (diff)
downloadlibguestfs-b5ff6816face6f8c1700d4f1df752c710620ff95.tar.gz
libguestfs-b5ff6816face6f8c1700d4f1df752c710620ff95.tar.xz
libguestfs-b5ff6816face6f8c1700d4f1df752c710620ff95.zip
Version 0.5: Numerous small fixes to make rpmbuild work again.0.5
Diffstat (limited to 'perl/Makefile.am')
-rw-r--r--perl/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/perl/Makefile.am b/perl/Makefile.am
index 2b5b1ddb..24548ed9 100644
--- a/perl/Makefile.am
+++ b/perl/Makefile.am
@@ -18,9 +18,12 @@
EXTRA_DIST = \
Makefile.PL.in \
Guestfs.xs \
- guestfs_perl.c \
typemap \
- perl/lib/Sys/Guestfs.pm
+ lib/Sys/Guestfs.pm \
+ examples/README \
+ examples/LICENSE \
+ examples/*.pl \
+ t/*.t
if HAVE_PERL
@@ -29,11 +32,13 @@ if HAVE_PERL
TESTS = run-perl-tests
+INSTALLDIRS = site
+
all:
- perl Makefile.PL
- make -f Makefile-pl
+ perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) PREFIX=$(prefix)
+ $(MAKE) -f Makefile-pl
install-data-hook:
- make -f Makefile-pl DESTDIR=$(DESTDIR) install
+ $(MAKE) -f Makefile-pl DESTDIR=$(DESTDIR) install
endif