summaryrefslogtreecommitdiffstats
path: root/perl/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-08 13:44:13 +0100
committerRichard Jones <rjones@redhat.com>2009-04-08 13:44:13 +0100
commit1ee6da96efe8340a7d3904a865d80cd59d9d3fde (patch)
tree41b5b106d06c65d24bd8216b88005654abc0e98d /perl/Makefile.am
parent8dcc88f867ab0bed24df49d8c0f347f1357bfffd (diff)
downloadlibguestfs-1ee6da96efe8340a7d3904a865d80cd59d9d3fde.tar.gz
libguestfs-1ee6da96efe8340a7d3904a865d80cd59d9d3fde.tar.xz
libguestfs-1ee6da96efe8340a7d3904a865d80cd59d9d3fde.zip
First version of Perl bindings, compiled but not tested.
Diffstat (limited to 'perl/Makefile.am')
-rw-r--r--perl/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/perl/Makefile.am b/perl/Makefile.am
index 6b12064a..ea9835b0 100644
--- a/perl/Makefile.am
+++ b/perl/Makefile.am
@@ -14,3 +14,23 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+EXTRA_DIST = \
+ Makefile.PL.in \
+ Guestfs.xs \
+ guestfs_perl.c \
+ typemap \
+ perl/lib/Sys/Guestfs.pm
+
+if HAVE_PERL
+
+# Interfacing automake and ExtUtils::MakeMaker known to be
+# a nightmare, news at 11.
+all:
+ perl Makefile.PL
+ make -f Makefile-pl
+
+install-data-hook:
+ make -f Makefile-pl DESTDIR=$(DESTDIR) install
+
+endif