summaryrefslogtreecommitdiffstats
path: root/perl/Makefile.am
diff options
context:
space:
mode:
authorHilko Bengen <bengen@hilluzination.de>2012-01-21 22:56:51 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-01-23 09:08:33 +0000
commitb6e0552ee5359da785bd1c08cadf022190e98720 (patch)
treedc27506bf79b6fb19f1d6aba1fda8087306416b3 /perl/Makefile.am
parent7004fafc6989efbbb1ef46723e8a91f936f16249 (diff)
downloadlibguestfs-b6e0552ee5359da785bd1c08cadf022190e98720.tar.gz
libguestfs-b6e0552ee5359da785bd1c08cadf022190e98720.tar.xz
libguestfs-b6e0552ee5359da785bd1c08cadf022190e98720.zip
Do not run appliance-related checks if not building appliance
Diffstat (limited to 'perl/Makefile.am')
-rw-r--r--perl/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/perl/Makefile.am b/perl/Makefile.am
index 7fc0eb67..404a4e91 100644
--- a/perl/Makefile.am
+++ b/perl/Makefile.am
@@ -46,9 +46,15 @@ src_deps: $(top_builddir)/src/libguestfs.la $(generator_built)
test_images:
$(MAKE) -C $(top_builddir)/tests/data
-TESTS = run-bindtests run-perl-tests
+TESTS = run-bindtests
+test_prereq = src_deps all test_images
-$(TESTS): src_deps all appliance test_images
+if ENABLE_APPLIANCE
+test_prereq += appliance
+TESTS += run-perl-tests
+endif
+
+$(TESTS): $(test_prereq)
TESTS_ENVIRONMENT = \
$(top_builddir)/run