summaryrefslogtreecommitdiffstats
path: root/ocaml/examples/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-09-30 15:32:41 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-09-30 16:14:35 +0100
commitd525103c8621f6ff0293311a8e8f9ac0c3580805 (patch)
tree65e5fd6115e3a1b7ab23513a303043be6632bf91 /ocaml/examples/Makefile.am
parentd278ef8ad9090441a713c7334804199318aeb3e1 (diff)
downloadlibguestfs-d525103c8621f6ff0293311a8e8f9ac0c3580805.tar.gz
libguestfs-d525103c8621f6ff0293311a8e8f9ac0c3580805.tar.xz
libguestfs-d525103c8621f6ff0293311a8e8f9ac0c3580805.zip
OCaml viewer: Use ocamlduce to replace xpath code.
Diffstat (limited to 'ocaml/examples/Makefile.am')
-rw-r--r--ocaml/examples/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/ocaml/examples/Makefile.am b/ocaml/examples/Makefile.am
index d088c4a9..b516647d 100644
--- a/ocaml/examples/Makefile.am
+++ b/ocaml/examples/Makefile.am
@@ -13,11 +13,11 @@ if BUILD_OCAML_VIEWER
noinst_SCRIPTS += viewer
-viewer: throbber.ml viewer.ml
- $(OCAMLFIND) ocamlopt \
+viewer: throbber.ml xmllight_loader.mli xmllight_loader.ml viewer.ml
+ ocamlducefind opt \
-warn-error A \
-thread \
- -package libvirt,lablgtk2,extlib,xml-light,threads -I .. \
+ -package libvirt,lablgtk2,extlib,xml-light,ocamlduce,threads -I .. \
-predicates init,threads \
-linkpkg mlguestfs.cmxa gtkThread.cmx \
$^ -o $@