summaryrefslogtreecommitdiffstats
path: root/ocaml/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-13 19:10:10 +0100
committerRichard Jones <rjones@redhat.com>2009-04-13 19:10:10 +0100
commit70c2ffc39677a9f5eb6b2230cb9ca2606b2fd966 (patch)
tree253e14c3aff908f3587ba219cb4071a240dbfec7 /ocaml/Makefile.am
parentb3f11c5f62f725fa3f09452b38d52dba764f80d0 (diff)
downloadlibguestfs-70c2ffc39677a9f5eb6b2230cb9ca2606b2fd966.tar.gz
libguestfs-70c2ffc39677a9f5eb6b2230cb9ca2606b2fd966.tar.xz
libguestfs-70c2ffc39677a9f5eb6b2230cb9ca2606b2fd966.zip
Additional test programs for Perl, Python, OCaml bindings.
Diffstat (limited to 'ocaml/Makefile.am')
-rw-r--r--ocaml/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
index 67f4a15c..0f1c3496 100644
--- a/ocaml/Makefile.am
+++ b/ocaml/Makefile.am
@@ -18,11 +18,13 @@
EXTRA_DIST = \
guestfs.mli guestfs.ml \
guestfs_c.c guestfs_c.h guestfs_c_actions.c \
- .depend META.in
+ .depend META.in \
+ t/*.ml
SUBDIRS = examples
CLEANFILES = *~ *.cmi *.cmo *.cmx *.cma *.cmxa *.o *.a *.so
+CLEANFILES += t/*~ t/*.cmi t/*.cmo t/*.o t/*.a t/*.so
if HAVE_OCAML
@@ -40,6 +42,22 @@ guestfs_c.o: guestfs_c.c
guestfs_c_actions.o: guestfs_c_actions.c
$(CC) $(CFLAGS) -I$(OCAMLLIB) -I$(top_builddir)/src -fPIC -Wall -c $<
+TESTS_ENVIRONMENT = \
+ LD_LIBRARY_PATH=$(abs_top_builddir)/src/.libs \
+ LIBGUESTFS_PATH=$(abs_top_builddir)
+
+TESTS = t/guestfs_005_load t/guestfs_010_launch t/guestfs_050_lvcreate
+noinst_DATA += $(TESTS)
+
+t/guestfs_005_load: t/guestfs_005_load.ml
+ $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
+
+t/guestfs_010_launch: t/guestfs_010_launch.ml
+ $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
+
+t/guestfs_050_lvcreate: t/guestfs_050_lvcreate.ml
+ $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
+
.mli.cmi:
$(OCAMLFIND) ocamlc -c $<
.ml.cmo:
@@ -66,4 +84,6 @@ install-data-hook:
guestfs \
META *.so *.a *.cma *.cmx *.cmxa *.cmi *.mli
+CLEANFILES += $(noinst_DATA)
+
endif \ No newline at end of file