summaryrefslogtreecommitdiffstats
path: root/ocaml/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-07-16 17:15:40 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-07-16 17:15:40 +0100
commitfd6fecea052b608db0e7b328b1b4a2669258a66f (patch)
tree28ff1fd84d7c9cea6a8422d06d4b18ebb829761c /ocaml/Makefile.am
parent7428b0a70caed014d0cb4126fe8a77432d8957c6 (diff)
downloadlibguestfs-fd6fecea052b608db0e7b328b1b4a2669258a66f.tar.gz
libguestfs-fd6fecea052b608db0e7b328b1b4a2669258a66f.tar.xz
libguestfs-fd6fecea052b608db0e7b328b1b4a2669258a66f.zip
Miscellaneous fixes for non-srcdir builds.
Diffstat (limited to 'ocaml/Makefile.am')
-rw-r--r--ocaml/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
index bf9760c3..b817cc37 100644
--- a/ocaml/Makefile.am
+++ b/ocaml/Makefile.am
@@ -76,11 +76,11 @@ t/guestfs_060_readdir: t/guestfs_060_readdir.ml mlguestfs.cmxa
$(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
.mli.cmi:
- $(OCAMLFIND) ocamlc -c $<
+ $(OCAMLFIND) ocamlc -c $< -o $@
.ml.cmo:
- $(OCAMLFIND) ocamlc -c $<
+ $(OCAMLFIND) ocamlc -c $< -o $@
.ml.cmx:
- $(OCAMLFIND) ocamlopt -c $<
+ $(OCAMLFIND) ocamlopt -c $< -o $@
depend: .depend