summaryrefslogtreecommitdiffstats
path: root/ocaml/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-08 17:19:09 +0100
committerRichard Jones <rjones@redhat.com>2009-04-08 17:19:09 +0100
commitb5ff6816face6f8c1700d4f1df752c710620ff95 (patch)
tree1ceb5097496c27ed3541e0b341b60a6b88e85ace /ocaml/Makefile.am
parentc3168fc03cdff6be5638107b12f74bc895af55ed (diff)
downloadlibguestfs-b5ff6816face6f8c1700d4f1df752c710620ff95.tar.gz
libguestfs-b5ff6816face6f8c1700d4f1df752c710620ff95.tar.xz
libguestfs-b5ff6816face6f8c1700d4f1df752c710620ff95.zip
Version 0.5: Numerous small fixes to make rpmbuild work again.0.5
Diffstat (limited to 'ocaml/Makefile.am')
-rw-r--r--ocaml/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
index de07b3be..62ffe2bb 100644
--- a/ocaml/Makefile.am
+++ b/ocaml/Makefile.am
@@ -17,7 +17,6 @@
EXTRA_DIST = \
guestfs.mli guestfs.ml \
- guestfs_internal.ml \
guestfs_c.c guestfs_c.h guestfs_c_actions.c \
.depend META.in
@@ -25,10 +24,10 @@ if HAVE_OCAML
noinst_DATA = mlguestfs.cma mlguestfs.cmxa META
-mlguestfs.cma: guestfs_c.o guestfs_c_actions.o guestfs_internal.cmo guestfs.cmo
+mlguestfs.cma: guestfs_c.o guestfs_c_actions.o guestfs.cmo
$(OCAMLMKLIB) -o mlguestfs $^ -lguestfs
-mlguestfs.cmxa: guestfs_c.o guestfs_c_actions.o guestfs_internal.cmx guestfs.cmx
+mlguestfs.cmxa: guestfs_c.o guestfs_c_actions.o guestfs.cmx
$(OCAMLMKLIB) -o mlguestfs $^ -lguestfs
guestfs_c.o: guestfs_c.c
@@ -56,7 +55,11 @@ SUFFIXES = .cmo .cmi .cmx .ml .mli .mll .mly
# Do the installation by hand, because we want to run ocamlfind.
install-data-hook:
- $(OCAMLFIND) install -destdir $(DESTDIR) guestfs \
+ mkdir -p $(DESTDIR)$(OCAMLLIB)
+ mkdir -p $(DESTDIR)$(OCAMLLIB)/stublibs
+ $(OCAMLFIND) install \
+ -ldconf ignore -destdir $(DESTDIR)$(OCAMLLIB) \
+ guestfs \
META *.so *.a *.cma *.cmx *.cmxa *.cmi *.mli
endif \ No newline at end of file