summaryrefslogtreecommitdiffstats
path: root/ocaml/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-07 16:52:25 +0100
committerRichard Jones <rjones@redhat.com>2009-04-07 16:52:25 +0100
commit4144e2106cc70ad8f1e081b57da09f9c1e276812 (patch)
tree55022dd599e4d1583b7c93de338d7c85c15a0fe7 /ocaml/Makefile.am
parent21ba59ce3cbc594ce9c7aeecd4dadb8430e4042d (diff)
downloadlibguestfs-4144e2106cc70ad8f1e081b57da09f9c1e276812.tar.gz
libguestfs-4144e2106cc70ad8f1e081b57da09f9c1e276812.tar.xz
libguestfs-4144e2106cc70ad8f1e081b57da09f9c1e276812.zip
Outline OCaml bindings.
Diffstat (limited to 'ocaml/Makefile.am')
-rw-r--r--ocaml/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
index 2b9e08ae..176bcec9 100644
--- a/ocaml/Makefile.am
+++ b/ocaml/Makefile.am
@@ -14,3 +14,49 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+if HAVE_OCAML
+
+EXTRA_DIST = \
+ guestfs.mli guestfs.ml \
+ guestfs_internal.ml \
+ guestfs_c.c guestfs_c.h guestfs_c_actions.c \
+ .depend META.in
+
+noinst_DATA = mlguestfs.cma mlguestfs.cmxa META
+
+mlguestfs.cma: guestfs_c.o guestfs_c_actions.o guestfs_internal.cmo guestfs.cmo
+ $(OCAMLMKLIB) -o mlguestfs $^ -lguestfs
+
+mlguestfs.cmxa: guestfs_c.o guestfs_c_actions.o guestfs_internal.cmx guestfs.cmx
+ $(OCAMLMKLIB) -o mlguestfs $^ -lguestfs
+
+guestfs_c.o: guestfs_c.c
+ $(CC) $(CFLAGS) -I$(OCAMLLIB) -c $<
+
+guestfs_c_actions.o: guestfs_c_actions.c
+ $(CC) $(CFLAGS) -I$(OCAMLLIB) -c $<
+
+.mli.cmi:
+ $(OCAMLFIND) ocamlc -c $<
+.ml.cmo:
+ $(OCAMLFIND) ocamlc -c $<
+.ml.cmx:
+ $(OCAMLFIND) ocamlopt -c $<
+
+depend: .depend
+
+.depend: $(wildcard *.mli) $(wildcard *.ml)
+ rm -f .depend
+ $(OCAMLFIND) ocamldep $^ > $@
+
+include .depend
+
+SUFFIXES = .cmo .cmi .cmx .ml .mli .mll .mly
+
+# Do the installation by hand, because we want to run ocamlfind.
+install-data-hook:
+ $(OCAMLFIND) install -destdir $(DESTDIR) guestfs \
+ META *.so *.a *.cma *.cmx *.cmxa *.cmi *.mli
+
+endif \ No newline at end of file