summaryrefslogtreecommitdiffstats
path: root/inspector/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-28 10:04:27 +0100
committerRichard Jones <rjones@redhat.com>2009-04-28 14:22:01 +0100
commit5aa57fbd34eb34922719d08712303b9d73ec215f (patch)
tree5f343365697fb38dbb4be12151e16f058b8e6f46 /inspector/Makefile.am
parent798b8dc5d84bc9b4884c67389950377ac2b97a66 (diff)
downloadlibguestfs-5aa57fbd34eb34922719d08712303b9d73ec215f.tar.gz
libguestfs-5aa57fbd34eb34922719d08712303b9d73ec215f.tar.xz
libguestfs-5aa57fbd34eb34922719d08712303b9d73ec215f.zip
Added virt-inspector program from virt-v2v.
Diffstat (limited to 'inspector/Makefile.am')
-rw-r--r--inspector/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/inspector/Makefile.am b/inspector/Makefile.am
new file mode 100644
index 00000000..528e183a
--- /dev/null
+++ b/inspector/Makefile.am
@@ -0,0 +1,38 @@
+# libguestfs virt-inspector
+# Copyright (C) 2009 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+EXTRA_DIST = \
+ virt-inspector.pl
+
+CLEANFILES = *~
+
+if HAVE_INSPECTOR
+
+man_MANS = virt-inspector.1
+
+virt-inspector.1: virt-inspector.pl
+ $(POD2MAN) \
+ --section 1 \
+ -c "Virtualization Support" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ $< > $@
+
+install-data-hook:
+ mkdir -p $(DESTDIR)$(bindir)
+ install -m 0755 virt-inspector.pl $(DESTDIR)$(bindir)/virt-inspector
+
+endif \ No newline at end of file