summaryrefslogtreecommitdiffstats
path: root/inspector/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-05-12 14:24:23 +0100
committerRichard Jones <rjones@redhat.com>2010-05-12 18:13:01 +0100
commitfeb0cd04822231f056c3086f322afbefc2e2467c (patch)
tree0566c4adba327da4886f8bb8b1807634e418afd4 /inspector/Makefile.am
parent48133118071a26950840fe33326c09130955c35e (diff)
downloadlibguestfs-feb0cd04822231f056c3086f322afbefc2e2467c.tar.gz
libguestfs-feb0cd04822231f056c3086f322afbefc2e2467c.tar.xz
libguestfs-feb0cd04822231f056c3086f322afbefc2e2467c.zip
po: Include strings from Perl programs in the PO files (RHBZ#559963).
xgettext will only recognize '*.pl' as being a Perl file (otherwise it treats it as a C file and does not correctly find any strings in it). This commit also fixes two actual bugs that xgettext found in the strings in our Perl programs.
Diffstat (limited to 'inspector/Makefile.am')
-rw-r--r--inspector/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/inspector/Makefile.am b/inspector/Makefile.am
index fc2bee36..e1fe44ab 100644
--- a/inspector/Makefile.am
+++ b/inspector/Makefile.am
@@ -58,3 +58,12 @@ TESTS_ENVIRONMENT = $(XMLLINT) --noout --relaxng virt-inspector.rng
endif
endif
+
+# Make symlink from virt-inspector.pl to virt-inspector. This is just
+# to keep xgettext happy since it uses the file extension to determine
+# the implementation language of a file.
+
+all-local: virt-inspector.pl
+
+virt-inspector.pl: virt-inspector
+ ln -sf $< $@