summaryrefslogtreecommitdiffstats
path: root/images/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-11-16 17:37:30 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-11-16 18:36:33 +0000
commitfcc631dedb894379cde01af563df3f6a364db7cb (patch)
tree41d8d1184c9e086d1d322538a6a5bc488cf897c3 /images/Makefile.am
parent9becb385b78eddb9b3817c6accaa6cdb3db0b5af (diff)
downloadlibguestfs-fcc631dedb894379cde01af563df3f6a364db7cb.tar.gz
libguestfs-fcc631dedb894379cde01af563df3f6a364db7cb.tar.xz
libguestfs-fcc631dedb894379cde01af563df3f6a364db7cb.zip
images: Make phony Windows image for testing.
Diffstat (limited to 'images/Makefile.am')
-rw-r--r--images/Makefile.am31
1 files changed, 29 insertions, 2 deletions
diff --git a/images/Makefile.am b/images/Makefile.am
index d97dd458..56880804 100644
--- a/images/Makefile.am
+++ b/images/Makefile.am
@@ -42,13 +42,19 @@ EXTRA_DIST = \
guest-aux/make-fedora-img.sh \
guest-aux/fedora-name.db.txt \
guest-aux/fedora-name.db \
- guest-aux/make-ubuntu-img.sh
+ guest-aux/make-ubuntu-img.sh \
+ guest-aux/make-windows-img.sh \
+ guest-aux/windows-software \
+ guest-aux/windows-software.reg \
+ guest-aux/windows-system \
+ guest-aux/windows-system.reg \
+ guest-aux/minimal-hive
noinst_DATA = test.iso
# This is 'check_DATA' because we don't need it until 'make check'
# time and we need the tools we have built in order to make it.
-check_DATA = debian.img fedora.img ubuntu.img
+check_DATA = debian.img fedora.img ubuntu.img windows.img
CLEANFILES = \
test.iso test.sqsh \
@@ -181,3 +187,24 @@ ubuntu.img: guest-aux/make-ubuntu-img.sh
LIBGUESTFS_PATH=../appliance \
LD_LIBRARY_PATH=../src/.libs \
bash $<
+
+# Make a (dummy) Windows image.
+windows.img: guest-aux/make-windows-img.sh \
+ guest-aux/windows-software guest-aux/windows-system
+ LIBGUESTFS_PATH=../appliance \
+ LD_LIBRARY_PATH=../src/.libs \
+ bash $<
+
+# Since users might not have the tools needed to create this, we
+# also distribute these files.
+guest-aux/windows-software: guest-aux/windows-software.reg
+ rm -f $@ $@-t
+ cp guest-aux/minimal-hive $@-t
+ hivexregedit --merge $@-t --prefix 'HKEY_LOCAL_MACHINE\SOFTWARE' $<
+ mv $@-t $@
+
+guest-aux/windows-system: guest-aux/windows-system.reg
+ rm -f $@ $@-t
+ cp guest-aux/minimal-hive $@-t
+ hivexregedit --merge $@-t --prefix 'HKEY_LOCAL_MACHINE\SYSTEM' $<
+ mv $@-t $@