summaryrefslogtreecommitdiffstats
path: root/images/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-05-29 12:59:32 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-05-29 12:59:32 +0100
commite02066bcb33a2aed5f23dd18c3168dc66efddb18 (patch)
tree266768938ae6c482890aa4061e1b10ee8e391ef7 /images/Makefile.am
parent75d260b6968309159f3335588f0e3f773d32a663 (diff)
downloadlibguestfs-e02066bcb33a2aed5f23dd18c3168dc66efddb18.tar.gz
libguestfs-e02066bcb33a2aed5f23dd18c3168dc66efddb18.tar.xz
libguestfs-e02066bcb33a2aed5f23dd18c3168dc66efddb18.zip
Use a squashfs attached as /dev/sdd during the C API tests.
Diffstat (limited to 'images/Makefile.am')
-rw-r--r--images/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/images/Makefile.am b/images/Makefile.am
index 68111071..dcdf51f8 100644
--- a/images/Makefile.am
+++ b/images/Makefile.am
@@ -18,4 +18,15 @@
EXTRA_DIST = \
helloworld.tar \
helloworld.tar.gz \
- mbr-ext2-empty.img.gz
+ mbr-ext2-empty.img.gz \
+ empty known-1 known-2 known-3
+
+noinst_DATA = test.sqsh
+
+CLEANFILES = test.sqsh
+
+squash_files = helloworld.tar helloworld.tar.gz empty known-1 known-2 known-3
+
+test.sqsh: $(squash_files)
+ rm -f $@
+ $(MKSQUASHFS) $(squash_files) $@