summaryrefslogtreecommitdiffstats
path: root/fuse/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-10-26 15:28:28 +0100
committerRichard W.M. Jones <rjones@redhat.com>2010-10-27 12:04:16 +0100
commitc66d6f215e8303d4eaf8ccfdb6a58cff04ccc485 (patch)
tree6a42e95590dffe4fd5a88e1ba52e15ad4a879c92 /fuse/Makefile.am
parentd600342b7d29c0176ff96a7807ebb38303ecb3a6 (diff)
downloadlibguestfs-c66d6f215e8303d4eaf8ccfdb6a58cff04ccc485.tar.gz
libguestfs-c66d6f215e8303d4eaf8ccfdb6a58cff04ccc485.tar.xz
libguestfs-c66d6f215e8303d4eaf8ccfdb6a58cff04ccc485.zip
Unify guestfish and guestmount options processing (RHBZ#642932).
In guestfish, factor out the processing of the options -a, -c, -d, -i, -m, -n, -r, -v, -V, -x into a separate set of files: options.c, options.h, inspect.c, virt.c. Change guestmount so that it uses these same files (from the ../fish directory) to process the same options. This unifies the handling of these options between the two programs. It also adds the useful inspection feature to guestmount, so you can now do: guestmount -d Guest -i --ro mnt/
Diffstat (limited to 'fuse/Makefile.am')
-rw-r--r--fuse/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/fuse/Makefile.am b/fuse/Makefile.am
index db0e418e..a122082e 100644
--- a/fuse/Makefile.am
+++ b/fuse/Makefile.am
@@ -23,7 +23,16 @@ if HAVE_FUSE
bin_PROGRAMS = guestmount
+# These source files (all related to option parsing) are shared
+# between guestfish and guestmount.
+SHARED_SOURCE_FILES = \
+ ../fish/inspect.c \
+ ../fish/options.h \
+ ../fish/options.c \
+ ../fish/virt.c
+
guestmount_SOURCES = \
+ $(SHARED_SOURCE_FILES) \
dircache.c \
dircache.h \
guestmount.c \
@@ -31,14 +40,16 @@ guestmount_SOURCES = \
guestmount_CFLAGS = \
-I$(top_srcdir)/src -I$(top_builddir)/src \
+ -I$(top_srcdir)/fish \
-I$(srcdir)/../gnulib/lib -I../gnulib/lib \
-DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
-DLOCALEBASEDIR=\""$(datadir)/locale"\" \
- $(FUSE_CFLAGS) \
+ $(FUSE_CFLAGS) $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
guestmount_LDADD = \
$(FUSE_LIBS) -lulockmgr \
+ $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
$(top_builddir)/src/libguestfs.la \
../gnulib/lib/libgnu.la