summaryrefslogtreecommitdiffstats
path: root/fish/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-07-13 13:06:26 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-07-14 14:08:31 +0100
commita86aa7d152ed996170714a3a4516eab58bf8b59d (patch)
treeb29a2081d1951b13c0da03d01973a0e8c507ba5b /fish/Makefile.am
parent5d6cc25900df4e13e4085f13d4f846cc9719ce61 (diff)
downloadlibguestfs-a86aa7d152ed996170714a3a4516eab58bf8b59d.tar.gz
libguestfs-a86aa7d152ed996170714a3a4516eab58bf8b59d.tar.xz
libguestfs-a86aa7d152ed996170714a3a4516eab58bf8b59d.zip
Guestfish feature: remote control of guestfish over a pipe.
The use case is to have a long-running guestfish process in a shell script, and thus to avoid the overhead of starting guestfish each time. Do: eval `guestfish --listen` guestfish --remote somecmd guestfish --remote someothercmd guestfish --remote exit This patch also supports having multiple guestfish processes at the same time. The protocol is simple XDR messages over a Unix domain socket.
Diffstat (limited to 'fish/Makefile.am')
-rw-r--r--fish/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/fish/Makefile.am b/fish/Makefile.am
index 03619f36..5255e853 100644
--- a/fish/Makefile.am
+++ b/fish/Makefile.am
@@ -29,10 +29,29 @@ guestfish_SOURCES = \
glob.c \
lcd.c \
more.c \
+ rc.c \
+ rc_protocol.c \
+ rc_protocol.h \
reopen.c \
time.c
+BUILT_SOURCES = \
+ rc_protocol.c \
+ rc_protocol.h
+
guestfish_CFLAGS = \
-I$(top_srcdir)/src -I$(top_builddir)/src -Wall \
-DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
guestfish_LDADD = $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
+
+if HAVE_RPCGEN
+rc_protocol.c: rc_protocol.x
+ rm -f $@-t
+ $(RPCGEN) -c -o $@-t $<
+ mv $@-t $@
+
+rc_protocol.h: rc_protocol.x
+ rm -f $@-t
+ $(RPCGEN) -h -o $@-t $<
+ mv $@-t $@
+endif