summaryrefslogtreecommitdiffstats
path: root/fish/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-01-29 14:56:13 +0000
committerRichard Jones <rjones@redhat.com>2010-01-29 15:11:59 +0000
commita6025c11d97ed5802b3729a93d224d2baa20ff12 (patch)
tree6dd670b706070e29496a62052447b22086434c0b /fish/Makefile.am
parent088d0c53cfe0dcb20b87707a9055175b2fd6b72f (diff)
downloadlibguestfs-a6025c11d97ed5802b3729a93d224d2baa20ff12.tar.gz
libguestfs-a6025c11d97ed5802b3729a93d224d2baa20ff12.tar.xz
libguestfs-a6025c11d97ed5802b3729a93d224d2baa20ff12.zip
Set locale in C programs so l10n works (RHBZ#559962).
This commit adds the calls to setlocale &c to all of the current C programs. It also adds l10n support to hivexget and hivexml which lacked them previously. To test this, try: LANG=pa_IN.UTF-8 guestfish --cmd-help (You can only do this test after installing the package, or at least the 'pa.mo' mo-file in the correct place).
Diffstat (limited to 'fish/Makefile.am')
-rw-r--r--fish/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/fish/Makefile.am b/fish/Makefile.am
index d817e6cf..43dce00f 100644
--- a/fish/Makefile.am
+++ b/fish/Makefile.am
@@ -59,6 +59,7 @@ guestfish_CFLAGS = \
-I$(top_srcdir)/src -I$(top_builddir)/src \
-I$(top_srcdir)/fish -I$(top_builddir)/fish \
-DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+ -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
-I$(srcdir)/../gnulib/lib -I../gnulib/lib \
$(WARN_CFLAGS) $(WERROR_CFLAGS)