summaryrefslogtreecommitdiffstats
path: root/fish/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-09-18 09:38:05 +0100
committerRichard W.M. Jones <rjones@redhat.com>2010-09-18 09:38:05 +0100
commit0003ea2c3dbaa7e22f4f616539136821d80694b8 (patch)
tree1a5bcededb436fb9f1a0e8e046599fdd0d5ae7f1 /fish/Makefile.am
parent585fceb3350c17a3d6ed7f2daffd5e2b3e5fc3e1 (diff)
downloadlibguestfs-0003ea2c3dbaa7e22f4f616539136821d80694b8.tar.gz
libguestfs-0003ea2c3dbaa7e22f4f616539136821d80694b8.tar.xz
libguestfs-0003ea2c3dbaa7e22f4f616539136821d80694b8.zip
generator: Generate guestfish-only commands.
The guestfish-only commands such as 'alloc' and 'edit' are now generated from one place in the generator instead of being spread around ad-hoc in the C code.
Diffstat (limited to 'fish/Makefile.am')
-rw-r--r--fish/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/fish/Makefile.am b/fish/Makefile.am
index 906d362f..4d17aa1b 100644
--- a/fish/Makefile.am
+++ b/fish/Makefile.am
@@ -23,6 +23,7 @@ generator_built = \
cmds.c \
completion.c \
guestfish-actions.pod \
+ guestfish-commands.pod \
prepopts.h \
prepopts.c
@@ -109,14 +110,15 @@ guestfish.static$(EXEEXT): $(guestfish_OBJECTS) $(guestfish_DEPENDENCIES)
$(guestfish_LINK) $(guestfish_OBJECTS) -static $(guestfish_LDADD) $(guestfish_LIBS) -ltinfo -lpcre -lhivex -lmagic -lz -lm
# Manual page.
-# guestfish-actions.pod is autogenerated. There is no include
-# mechanism for POD, so we have to do it by hand.
+# guestfish-actions.pod and guestfish-commands.pod are autogenerated.
+# There is no include mechanism for POD, so we have to do it by hand.
man_MANS = guestfish.1
-guestfish.1: guestfish.pod guestfish-actions.pod
+guestfish.1: guestfish.pod guestfish-actions.pod guestfish-commands.pod
sed \
-e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
+ -e '/@FISH_COMMANDS@/rguestfish-commands.pod' -e 's/@FISH_COMMANDS@//' \
< $< | \
$(POD2MAN) \
--section 1 \