summaryrefslogtreecommitdiffstats
path: root/fish/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-08-21 19:05:20 +0200
committerJim Meyering <meyering@redhat.com>2009-08-24 18:15:06 +0200
commit6cd965e007f65d6e62872c6ddd782f1de06046e3 (patch)
treed58f3636b093c0ac1e60963ca4ac8c51ffb36520 /fish/Makefile.am
parentacdf8907dee4fad3049bcc19921ffa96b9b5376b (diff)
downloadlibguestfs-6cd965e007f65d6e62872c6ddd782f1de06046e3.tar.gz
libguestfs-6cd965e007f65d6e62872c6ddd782f1de06046e3.tar.xz
libguestfs-6cd965e007f65d6e62872c6ddd782f1de06046e3.zip
guestfish: write --help to stdout, use gnulib's progname module
* fish/fish.c: Include "progname.h". (main): Call set_program_name to initialize. Don't hard-code guestfish everywhere. Use program_name. However, be careful when modifying argv[0], since it is used in the hopes that it is an absolute file name. (usage): Don't spew all of --help for a mis-typed option. Split long lines.
Diffstat (limited to 'fish/Makefile.am')
-rw-r--r--fish/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/fish/Makefile.am b/fish/Makefile.am
index 94bf7570..c8ba3ea4 100644
--- a/fish/Makefile.am
+++ b/fish/Makefile.am
@@ -52,13 +52,14 @@ guestfish_CFLAGS = \
-I$(top_srcdir)/src -I$(top_builddir)/src \
-I$(top_srcdir)/fish -I$(top_builddir)/fish \
-DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+ -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
guestfish_LDADD = $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
# Make libguestfs use the convenience library.
noinst_LTLIBRARIES = librc_protocol.la
-guestfish_LDADD += librc_protocol.la
+guestfish_LDADD += librc_protocol.la ../gnulib/lib/libgnu.la
if HAVE_RPCGEN
rc_protocol.c: rc_protocol.x