summaryrefslogtreecommitdiffstats
path: root/fish/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-12-31 12:26:04 +0000
committerRichard Jones <rjones@redhat.com>2009-12-31 12:26:04 +0000
commit8980c01b46eafcf4b5dc127e4696c2cbe1bff09f (patch)
treebc8dc1c3867f44cd0b5d5650202d832b102a6010 /fish/Makefile.am
parent500ab86509e819cdf9c379f0bf6f0076bdd2ab68 (diff)
downloadlibguestfs-8980c01b46eafcf4b5dc127e4696c2cbe1bff09f.tar.gz
libguestfs-8980c01b46eafcf4b5dc127e4696c2cbe1bff09f.tar.xz
libguestfs-8980c01b46eafcf4b5dc127e4696c2cbe1bff09f.zip
Move guestfs(3) and guestfish(1) man pages into subdirectories.
These manual pages have for a very long time 'lived' in the top source directory. Clean up this situation by moving those manual pages (plus associated generated files) into the src/ and fish/ subdirectories respectively.
Diffstat (limited to 'fish/Makefile.am')
-rw-r--r--fish/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/fish/Makefile.am b/fish/Makefile.am
index 795952a9..1652c545 100644
--- a/fish/Makefile.am
+++ b/fish/Makefile.am
@@ -21,7 +21,8 @@ bin_PROGRAMS = guestfish
generator_built = \
cmds.c \
- completion.c
+ completion.c \
+ guestfish-actions.pod
BUILT_SOURCES = \
$(generator_built) \
@@ -79,3 +80,20 @@ rc_protocol.h: rc_protocol.x
$(RPCGEN) -h -o $@-t $<
mv $@-t $@
endif
+
+# Manual page.
+# guestfish-actions.pod is autogenerated. There is no include
+# mechanism for POD, so we have to do it by hand.
+
+man_MANS = guestfish.1
+
+guestfish.1: guestfish.pod guestfish-actions.pod
+ sed \
+ -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
+ < $< | \
+ $(POD2MAN) \
+ --section 1 \
+ -c "Virtualization Support" \
+ --name "guestfish" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ > $@