summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-05-17 15:04:56 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-05-17 17:05:12 +0100
commit34acb80a28d1b48e734883a32f7f3344dc216ec0 (patch)
treeedb50a9af2c1fc2d590c38fe1a644a11068806ef /examples/Makefile.am
parent8c0aca8d9280fb87027826fe89d70cc2701e7f8b (diff)
downloadlibguestfs-34acb80a28d1b48e734883a32f7f3344dc216ec0.tar.gz
libguestfs-34acb80a28d1b48e734883a32f7f3344dc216ec0.tar.xz
libguestfs-34acb80a28d1b48e734883a32f7f3344dc216ec0.zip
Enable deprecation warnings on all C programs.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 00a52676..952d6026 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -28,6 +28,7 @@ endif
create_disk_SOURCES = create_disk.c
create_disk_CFLAGS = \
+ -DGUESTFS_WARN_DEPRECATED=1 \
-I$(top_srcdir)/src -I$(top_builddir)/src \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
create_disk_LDADD = \
@@ -35,6 +36,7 @@ create_disk_LDADD = \
inspect_vm_SOURCES = inspect_vm.c
inspect_vm_CFLAGS = \
+ -DGUESTFS_WARN_DEPRECATED=1 \
-I$(top_srcdir)/src -I$(top_builddir)/src \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
inspect_vm_LDADD = \
@@ -42,6 +44,7 @@ inspect_vm_LDADD = \
virt_dhcp_address_SOURCES = virt-dhcp-address.c
virt_dhcp_address_CFLAGS = \
+ -DGUESTFS_WARN_DEPRECATED=1 \
-I$(top_srcdir)/src -I$(top_builddir)/src \
$(WARN_CFLAGS) $(WERROR_CFLAGS) \
$(HIVEX_CFLAGS)