summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-07-31 20:48:00 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-07-31 21:04:48 +0100
commit1d134301fc4d05338d09517abc978d0a90d82e09 (patch)
treecfa55a625dbbaffbd5ce04fc44e4261cad2ed473 /debian
parentbad3f4b54a959685f3c0697238fc5753096834fb (diff)
downloadlibguestfs-1d134301fc4d05338d09517abc978d0a90d82e09.tar.gz
libguestfs-1d134301fc4d05338d09517abc978d0a90d82e09.tar.xz
libguestfs-1d134301fc4d05338d09517abc978d0a90d82e09.zip
debian: Build libguestfs-ocaml and libguestfs-ocaml-dev subpackages.
Diffstat (limited to 'debian')
-rw-r--r--debian/.gitignore5
-rw-r--r--debian/control52
-rw-r--r--debian/libguestfs-ocaml-dev.examples1
-rw-r--r--debian/libguestfs-ocaml-dev.install.in4
-rw-r--r--debian/libguestfs-ocaml.install.in1
-rwxr-xr-xdebian/rules3
6 files changed, 64 insertions, 2 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
index f7436485..57f612bb 100644
--- a/debian/.gitignore
+++ b/debian/.gitignore
@@ -3,10 +3,15 @@
*.substvars
changelog
files
+guestfsd/
guestfish/
guestmount/
libguestfs-dev/
libguestfs-doc/
+libguestfs-ocaml/
+libguestfs-ocaml.install
+libguestfs-ocaml-dev/
+libguestfs-ocaml-dev.install
libguestfs-perl/
libguestfs-tools/
libguestfs0-dbg/
diff --git a/debian/control b/debian/control
index 2a19441f..fc49041a 100644
--- a/debian/control
+++ b/debian/control
@@ -25,7 +25,9 @@ Build-Depends: debhelper (>= 7), dpkg-dev, devscripts, autotools-dev,
# FUSE
libfuse-dev, fuse-utils,
# virt-resize
- libpcre-ocaml-dev
+ libpcre-ocaml-dev,
+# Debian OCaml
+ dh-ocaml
Homepage: http://libguestfs.org
Standards-Version: 3.8.2
@@ -243,3 +245,51 @@ Description: library for accessing and modifying guest disk images
the guest. Also you can upload and download files and directories.
.
This package contains the Perl bindings.
+
+Package: libguestfs-ocaml
+Architecture: any
+Depends: ${ocaml:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Provides: ${ocaml:Provides}
+Description: library for accessing and modifying guest disk images
+ libguestfs is a library for accessing and modifying guest disk images. Amongst
+ the things this is good for: making batch configuration changes to guests,
+ viewing and editing files inside guests, getting disk used/free statistics,
+ migrating between virtualization systems, performing partial backups,
+ performing partial guest clones, cloning guests and changing
+ registry/UUID/hostname info, and much else besides.
+ .
+ It uses Linux kernel and qemu code, and can access any type of guest
+ filesystem that Linux and qemu can, including but not limited to: ext2/3/4,
+ btrfs, FAT and NTFS, LVM, many different disk partition schemes, qcow, qcow2,
+ vmdk.
+ .
+ libguestfs provides ways to enumerate guest storage (eg. partitions, LVs, what
+ filesystem is in each LV, etc.). It can also run commands in the context of
+ the guest. Also you can upload and download files and directories.
+ .
+ This package contains the OCaml bindings (runtime).
+
+Package: libguestfs-ocaml-dev
+Architecture: any
+Depends: libguestfs-ocaml, libguestfs-dev, ocaml-findlib,
+ ${ocaml:Depends},
+ ${misc:Depends}
+Provides: ${ocaml:Provides}
+Description: library for accessing and modifying guest disk images
+ libguestfs is a library for accessing and modifying guest disk images. Amongst
+ the things this is good for: making batch configuration changes to guests,
+ viewing and editing files inside guests, getting disk used/free statistics,
+ migrating between virtualization systems, performing partial backups,
+ performing partial guest clones, cloning guests and changing
+ registry/UUID/hostname info, and much else besides.
+ .
+ It uses Linux kernel and qemu code, and can access any type of guest
+ filesystem that Linux and qemu can, including but not limited to: ext2/3/4,
+ btrfs, FAT and NTFS, LVM, many different disk partition schemes, qcow, qcow2,
+ vmdk.
+ .
+ libguestfs provides ways to enumerate guest storage (eg. partitions, LVs, what
+ filesystem is in each LV, etc.). It can also run commands in the context of
+ the guest. Also you can upload and download files and directories.
+ .
+ This package contains the OCaml bindings.
diff --git a/debian/libguestfs-ocaml-dev.examples b/debian/libguestfs-ocaml-dev.examples
new file mode 100644
index 00000000..56bc35ed
--- /dev/null
+++ b/debian/libguestfs-ocaml-dev.examples
@@ -0,0 +1 @@
+ocaml/examples/*.ml
diff --git a/debian/libguestfs-ocaml-dev.install.in b/debian/libguestfs-ocaml-dev.install.in
new file mode 100644
index 00000000..55ea3857
--- /dev/null
+++ b/debian/libguestfs-ocaml-dev.install.in
@@ -0,0 +1,4 @@
+@OCamlStdlibDir@/guestfs/META
+@OCamlStdlibDir@/guestfs/*.a
+@OCamlStdlibDir@/guestfs/*.cm*
+@OCamlStdlibDir@/guestfs/*.ml*
diff --git a/debian/libguestfs-ocaml.install.in b/debian/libguestfs-ocaml.install.in
new file mode 100644
index 00000000..1d5ce78c
--- /dev/null
+++ b/debian/libguestfs-ocaml.install.in
@@ -0,0 +1 @@
+@OCamlDllDir@/*.so
diff --git a/debian/rules b/debian/rules
index da6272ea..01b83297 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,7 @@ DEB_BUILD_OPTIONS=nocheck
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/autotools.mk
include /usr/share/cdbs/1/class/python-distutils.mk
+include /usr/share/cdbs/1/rules/ocaml.mk
DEB_CONFIGURE_EXTRA_FLAGS := \
--with-java-home=no \
@@ -19,7 +20,7 @@ DEB_CONFIGURE_EXTRA_FLAGS := \
--disable-haskell \
--disable-php \
--with-readline \
- --enable-install-daemon \
+ --enable-install-daemon \
--with-python-installdir=/usr/share/pyshared
DEB_DBG_PACKAGES = libguestfs0-dbg