summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-11-24 11:41:13 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-12-09 16:41:40 +0000
commit8e7012131cbf406a936efbbe688aec253bd742a0 (patch)
treea9f4cc0cc6369fc4e84ec4eeb97e57b4a7993434 /debian/rules
parentb5516dc9d4a1418ad683aa7f046aa7fa30152721 (diff)
downloadlibguestfs-8e7012131cbf406a936efbbe688aec253bd742a0.tar.gz
libguestfs-8e7012131cbf406a936efbbe688aec253bd742a0.tar.xz
libguestfs-8e7012131cbf406a936efbbe688aec253bd742a0.zip
Add debian/ directory (temporarily).
This was created initially from pkg-libvirt/libguestfs.git commit 680ff0b0e8c9133ef987e68392bd3990715f6891. This is a temporary measure to allow us to build Debian and Ubuntu packages more easily. When downstream packaging is being done on these distros we will remove this directory again. To build a Debian package, use this command: debuild -i -us -uc -b
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules47
1 files changed, 47 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..1d6a9048
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,47 @@
+#!/usr/bin/make -f
+
+DEB_PYTHON_SYSTEM=pysupport
+DEB_DH_INSTALL_SOURCEDIR = debian/tmp
+DEB_VENDOR=$(shell dpkg-vendor --query vendor)
+
+# Comment this to enable 'make check'
+DEB_BUILD_OPTIONS=nocheck
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/class/python-distutils.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+
+DEB_CONFIGURE_EXTRA_FLAGS := \
+ --with-java-home=no \
+ --disable-ruby \
+ --disable-haskell \
+ --disable-php \
+ --with-readline \
+ --with-python-installdir=/usr/share/pyshared
+
+DEB_DBG_PACKAGES = libguestfs0-dbg
+DEB_PYTHON_SETUP_CMD := /dev/null
+#DEB_DH_MAKESHLIBS_ARGS_python-guestfs = -X usr/lib/pyshared
+
+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+debian/check-stamp:
+ for TEST in ${DEBIAN_SKIP_TEST}; do \
+ export $$TEST=1; \
+ done; \
+ make check
+ touch debian/check-stamp
+
+build/guestfish:: debian/check-stamp
+endif
+
+#install/python-guestfs::
+# rm -f debian/tmp/usr/lib/python*/*/libguestfsmod.so
+# for mod in debian/tmp/usr/lib/python*/*/libguestfsmod.so.0.0.0; do \
+# mv $${mod} $$(dirname $${mod})/libguestfsmod.so; \
+# done
+
+clean::
+ rm -rf perl/blib/ perl/*.o
+ rm -f src/.pod2text.data
+ rm -f debian/check-stamp