summaryrefslogtreecommitdiffstats
path: root/daemon/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-07-27 22:27:45 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-07-28 10:57:57 +0100
commit0f2e9c84e9ff1071260770930068642ecc8ac0d9 (patch)
treef4e466d6fb3710d589c21c8849c27f9f2f55ced2 /daemon/configure.ac
parentbf920f57677c67f903cf8c4c985ce3d290b1dbde (diff)
downloadlibguestfs-0f2e9c84e9ff1071260770930068642ecc8ac0d9.tar.gz
libguestfs-0f2e9c84e9ff1071260770930068642ecc8ac0d9.tar.xz
libguestfs-0f2e9c84e9ff1071260770930068642ecc8ac0d9.zip
Replace shell_quote function with %Q and %R printf specifiers.
%Q => simple shell quoted string %R => path will be prefixed by /sysroot eg. snprintf (cmd, sizeof cmd, "cat %R", path); system (cmd);
Diffstat (limited to 'daemon/configure.ac')
-rw-r--r--daemon/configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/daemon/configure.ac b/daemon/configure.ac
index dc6936bf..243f353a 100644
--- a/daemon/configure.ac
+++ b/daemon/configure.ac
@@ -65,6 +65,22 @@ AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
dnl Functions which may not be available in older distributions.
AC_CHECK_FUNCS([futimens listxattr llistxattr getxattr lgetxattr setxattr lsetxattr removexattr lremovexattr])
+dnl For modified printf, we need glibc either (old-style)
+dnl register_printf_function or (new-style) register_printf_specifier.
+AC_CHECK_FUNC([register_printf_specifier],[
+ AC_DEFINE([HAVE_REGISTER_PRINTF_SPECIFIER],[1],
+ [Define to 1 if you have new-style register_printf_specifier])
+ ],[
+ AC_CHECK_FUNC([register_printf_function],[
+ AC_DEFINE([HAVE_REGISTER_PRINTF_FUNCTION],[1],
+ [Define to 1 if you have old-style register_printf_function])
+ ],[
+ AC_MSG_FAILURE(
+[No support for glibc-style extended printf formatters.
+
+This means you either have a very old glibc (pre-2.0) or you
+are using some other libc where this is not supported.])])])
+
dnl Headers.
AC_CHECK_HEADERS([attr/xattr.h sys/xattr.h])