summaryrefslogtreecommitdiffstats
path: root/daemon/configure.ac
diff options
context:
space:
mode:
authorrjones <rjones>2009-03-03 08:58:37 +0000
committerrjones <rjones>2009-03-03 08:58:37 +0000
commit28d760b1542da7ff83b18c4ca60c2d03f327c2f4 (patch)
tree28b49a8622a47cf24ad2af48dce554bcef8bb4d9 /daemon/configure.ac
downloadlibguestfs-28d760b1542da7ff83b18c4ca60c2d03f327c2f4.tar.gz
libguestfs-28d760b1542da7ff83b18c4ca60c2d03f327c2f4.tar.xz
libguestfs-28d760b1542da7ff83b18c4ca60c2d03f327c2f4.zip
Build environment set up for libguestfs.
Diffstat (limited to 'daemon/configure.ac')
-rw-r--r--daemon/configure.ac56
1 files changed, 56 insertions, 0 deletions
diff --git a/daemon/configure.ac b/daemon/configure.ac
new file mode 100644
index 00000000..26fefe50
--- /dev/null
+++ b/daemon/configure.ac
@@ -0,0 +1,56 @@
+# libguestfs-daemon
+# Copyright (C) 2009 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+AC_INIT([libguestfs-daemon],[0.1])
+AM_INIT_AUTOMAKE
+
+dnl Make sure the user has created the link to nfs-utils source.
+if ! test -e $srcdir/nfs-utils \
+ -o -f $srcdir/nfs-utils/utils/nfsd/nfsd.c; then
+ AC_MSG_ERROR([$srcdir/nfs-utils must be a symlink to the unpacked nfs-utils sources.
+See the README file for more information.])
+fi
+
+dnl If the user specified --enable-32bit, then force the C compiler
+dnl to build 32 bit binaries (gcc -m32).
+AC_ARG_ENABLE([32bit],
+ [AS_HELP_STRING([--enable-32bit], [build 32 bit binaries (gcc -m32)])],
+ [CC="gcc -m32"],
+ [enable_32bit=no])
+
+dnl Check for basic C environment.
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_CPP
+
+AC_C_PROTOTYPES
+test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
+
+AC_PROG_CC_C_O
+
+dnl Check for XDR library.
+AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
+ AC_SEARCH_LIBS([xdrmem_create],[rpc xdr nsl])
+ ])
+
+dnl Run in subdirs.
+AC_CONFIG_SUBDIRS([nfs-utils])
+
+dnl Produce output files.
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT