summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorMatthew Booth <mbooth@redhat.com>2011-04-07 15:30:54 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-04-07 16:37:20 +0100
commit3a84e0784e1e3ab7b56850d0f8c9aa42f1ae3da1 (patch)
treeb48d5f29ed2bedb87305fd54de1633bf796322fb /daemon/Makefile.am
parent6ea263b1f141614e7693a38b13e8f368237760a2 (diff)
downloadlibguestfs-3a84e0784e1e3ab7b56850d0f8c9aa42f1ae3da1.tar.gz
libguestfs-3a84e0784e1e3ab7b56850d0f8c9aa42f1ae3da1.tar.xz
libguestfs-3a84e0784e1e3ab7b56850d0f8c9aa42f1ae3da1.zip
Compile rpcgen-generated files with -fno-strict-aliasing
rpcgen generates source which can't be safely compiled with strict-aliasing enabled.
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index ee1959f5..8fb070f6 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -45,13 +45,12 @@ BUILT_SOURCES = \
EXTRA_DIST = $(BUILT_SOURCES) \
.gitignore
-# This convenience library is solely to avoid compiler warnings
-# in its generated sources.
noinst_LIBRARIES = libprotocol.a
-libprotocol_a_SOURCES = \
- guestfs_protocol.c \
- guestfs_protocol.h
-libprotocol_a_CFLAGS =
+
+# This convenience library is solely to compile its generated sources with
+# custom flags.
+libprotocol_a_SOURCES = guestfs_protocol.c guestfs_protocol.h
+libprotocol_a_CFLAGS = -Wall -Wno-unused -fno-strict-aliasing
guestfs_protocol.c: $(libsrcdir)/guestfs_protocol.c
rm -f $@